www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: some warnings when compiling for windows

some warnings when compiling for windows

From: Vincent Torri <vincent.torri_at_gmail.com>
Date: Mon, 31 Oct 2011 10:53:45 +0100

hey

i get some warnings when cross compiling (i use gcc 4.7.0) :

/home/torri/local/opt/mingw-w64-x86_32/bin/../lib/gcc/i686-w64-mingw32/4.7.0/../../../../i686-w64-mingw32/include/winsock2.h:15:2:
warning: #warning Please include winsock2.h before windows.h [-Wcpp]

and a lot of

/opt/efl/include/gcrypt.h:1590:35: warning: ‘gcry_*******’ is deprecated
[-Wdeprecated-declarations]

regards

Vincent Torri

_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2011-10-31

the libssh2 team