www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: libssh2 - help

Re: libssh2 - help

From: Peter Stuge <peter_at_stuge.se>
Date: Fri, 9 Oct 2020 14:39:33 +0000

Geetha wrote:
> After so many research I have compiled libssh2 for windows mobile 6.0 but
> when I linked those libssh2.lib in my project I am getting many linker
> errors related to openssl.

Well done building the library for Windows Mobile!

libssh2 requires crypto functionality from another library or API. When
libssh2 is built to use OpenSSL and you want to link libssh2.lib to your
application then you must make sure to also link that same version of
OpenSSL to your application, so that libssh2 has access to OpenSSL.

PS: Please always start a new thread for each topic that you ask about,
please avoid replying to messages about other topics, because email
programs link these messages together invisibly and many email software
will then display your message within an unrelated discussion, which is
confusing for everyone. Thanks a lot!

//Peter
_______________________________________________
libssh2-devel https://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2020-10-09

the libssh2 team