www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples

Archive Index This month's Index

Subject: Re: release time?

Re: release time?

From: Daniel Stenberg <daniel_at_haxx.se>
Date: Fri, 15 Jan 2010 09:20:54 +0100 (CET)

On Fri, 15 Jan 2010, Peter Stuge wrote:

> we should actually rename LIBSSH2_ERROR_PUBLICKEY_UNRECOGNIZED to something
> like LIBSSH2_ERROR_AUTHENTICATION_FAILED and use that error code for all
> failed authentication attempts, regardless of the method used.
>
> Can we do this rename? It means changing the API. We could keep a
> backwards-compatible alias define and mark _PUBLICKEY_UNRECOGNIZED as
> deprecated, I guess that is as good as it gets?

I'm totally fine with doing the rename with a backwards-compatible alias
define.

-- 
  / daniel.haxx.se
_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2010-01-15

the libssh2 team