www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: libssh2 V1.9.0 vulnerability CVE-2019-17498

libssh2 V1.9.0 vulnerability CVE-2019-17498

From: Sarathe, Omprakash <omprakash.sarathe_at_siemens.com>
Date: Thu, 11 Mar 2021 17:46:30 +0000

Hi All,

As per CVE-2019-17498 there is a vulnerability with libssh2 version 1.9.0(Please see below more detail). Can you please confirm the official release date of libssh2 having CVE-2019-17498 vulnerability fix.

CVE-2019-17498
In libssh2 v1.9.0 and earlier versions, the SSH_MSG_DISCONNECT logic in packet.c has an integer overflow in a bounds check, enabling an attacker to specify an arbitrary (out-of-bounds) offset for a subsequent memory read. A crafted SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server.

With Best Regards
Omprakash

_______________________________________________
libssh2-devel https://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2021-03-11

the libssh2 team