www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: some warnings when compiling for windows

Re: some warnings when compiling for windows

From: Vincent Torri <vincent.torri_at_gmail.com>
Date: Mon, 31 Oct 2011 13:27:42 +0100

2011/10/31 Henrik Nordström <henrik_at_henriknordstrom.net>

> mån 2011-10-31 klockan 12:41 +0100 skrev Daniel Stenberg:
>
> > > /opt/efl/include/gcrypt.h:1590:35: warning: ‘gcry_*******’ is
> deprecated
> > > [-Wdeprecated-declarations]
> >
> > Surely those can't be "blamed" on us?
>
> Only if it's due to libssh2 using deprecated parts of libgcrypt.
>
> What exactly do the warnign say?
>

1 example (there are tons of similar messages):

/opt/efl/include/gcrypt.h:1512:1: warning: 'gcry_ac_key_t' is deprecated
[-Wdeprecated-declarations]

>
> And which version of libgcrypt are you compiling with?
>

libgcrypt 1.5.0

regards

Vincent Torri

_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2011-10-31

the libssh2 team